Litify Inbox Outage
Incident Report for Litify
Resolved
Litify Inbox is operational.
Posted Jun 26, 2023 - 17:32 EDT
Monitoring
The Litify Inbox outage was caused by a temporary server outage. This has been resolved, but we're continuing to monitor.
Posted Jun 26, 2023 - 17:19 EDT
Investigating
Litify Inbox is currently experiencing an outage. The tool will spin and say 'Connecting to Litify.' We are actively investigating.
Posted Jun 26, 2023 - 16:17 EDT
This incident affected: Litify Integrations (Litify Inbox).