Docrio Email Outage

Incident Report for Litify

Resolved

We have confirmed the issue is resolved. Please reach out to Litify Support if additional issues are experienced.
Posted Oct 16, 2025 - 12:44 EDT

Monitoring

The implementation of the fix has been completed with positive results. We are continuing to monitor.
Posted Oct 16, 2025 - 12:31 EDT

Identified

We have identified the issue and are actively implementing a fix.
Posted Oct 16, 2025 - 12:09 EDT

Investigating

Docrio Email/Calendar is currently experiencing an outage. Users are reporting being unable to log into the add-in and receiving multiple emails noting 'Something has changed with your account and we are no longer able to verify your previous login.' Litify's Engineering team is currently investigating.
Posted Oct 16, 2025 - 11:40 EDT
This incident affected: Docrio Email and Docrio Calendar Sync.